add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

First Build wont power up

Devun41
  • 24 months ago

I plugged everything in, made sure outlet is right, i turned it on right, however only one LED light on the front panel lights up and nothing else starts up including the case fans connected straight to the power supply.

https://pcpartpicker.com/user/Devun41/saved/#view=GnKTHx

Comments

  • 24 months ago
  • 2 points

I hate to get off topic, but why these parts in 2018?

  • 24 months ago
  • 1 point

budget. first build.

  • 24 months ago
  • 1 point

dude a new ryzen apu is cheeper and better than that

  • 24 months ago
  • 1 point

theres no going back now fellas ;)

  • 24 months ago
  • 1 point

front panels connectors plugged in correctly?? does absolutely nothing happen when you press the power button? 24pin and 8 pin eps plugged in right?

  • 24 months ago
  • 1 point

Update: 1 led works, fans turn on but for about 10 seconds then turns off... will he posting pics

  • 24 months ago
  • 1 point

Update 2: fans stay on, graphics card fans runs, still one led(not a big deal) will be plugging in to keyboard, mouse, monitor later today.

  • 24 months ago
  • 1 point

Read the MOBO manual and check to make sure all the little pin connections are in. And quoting Brock, check the 24 and 8-pin connections.

Skip to 17minutes in the following video and watch what he does, it goes through step-by-step where every power connector goes. Now, it may vary based on your MOBO but again, check your manual: https://www.youtube.com/watch?v=0bUghCx9iso

Lastly, make sure your video card and ram sticks are plugged in the right slots according to the manual. My MOBO was fairly specific about where those two parts went. Good luck!

[comment deleted by staff]

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube