add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

New CPU cooler turns on and off

Sl63095

1 month ago

Hi, my new cooler came in. I installed it and the fan turns on for a few seconds, then it loses power and this process just repeats until eventually, it stops turning on at all. I plugged it into a different motherboard that is wayyyy older and it worked fine. I'm wondering if its a power issue? This website rates the TDP at 10W, the manufacturer rates it at 70w TDP on their site. The cpu cooler is Raijintek Juno x RGB and the power supply is an EVGA 430W plus. Also the motherboard is an MSI b250m pro-vd. Any help is appreciated !

Comments

  • 29 days ago
  • 2 points

I would go into the bios and see if it has settings for the cpu fan connector. It is a pwm fan and 4 pin mobo it should work. IDK if the RGB will work, I don't see anything about it on MSI page so you may need a controller for rgb.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube