add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube
Unhandybirch656

7 months ago

Hi, so I've run into an issue that I can't seem to fix. Every time I play some games i.e. smite, tf2, or Apex legends, I get constant freezes and, when I look at my task manager, I see that superfetch is taking up the vast majority of my disk, which is obviously causing the problem. However, after disabling it, I've found that everything has become much slower and using my PC had become much harder than it used to be. Is there any way to stop superfetch's allocation problems without disabling it? Thanks in advance!

Comments

  • 7 months ago
  • 1 point

Superfetch is actually a service that loads items into RAM faster, based on what the program you are currently using has used in the past. Disabling it would be a massive mistake. The constant freezes are likely coming from one of four things: Too much items loaded into RAM, too much load on the CPU or GPU, or a near-failing hard disk, in which case it would need to be replaced. (Also for TF2, it freezes so often even on powerful hardware, it's no concern).

In short, do NOT disable Superfetch. Something else is causing the issue.

  • 7 months ago
  • 1 point

I have to disagree on some points.

When I didn't have an SSD for Windows 10 and was running it from an HDD -- my girlfriend still has an HDD in her laptop, it just hogged the drive so much that after turning on the PC I was unable to do anything. After disabling it, it allowed me to use the PC. For my girlfriend (some cheap 5200 RPM rated HDD -- I assume) it wasn't rare that she had to wait half an hour until the PC became usable (especially after a Windows update, or if other application wanted to use the drive too). All of this after you logged in.

So I disabled Superfetch. The HDD wasn't hogged and the PC became usable. Maybe it get some slow-downs, but since I am a bloody gamer, I don't care about if an application would take a few seconds shorter to start as long as my PC doesn't take 10 minutes longer to became usable.

The solution is not to use Windows.

Or get an SSD so Superfetch can be done with whatever it's doing as soon as possible.

If you still have an HDD, I'd say disable Superfetch.

  • 7 months ago
  • 1 point

I've had similar experiences, so I can agree.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube