add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Who should I call when having RAM problems mobo or memory manufacturer?

mhweb
  • 4 months ago

I recently purchased a 128GB RAM kit for my second gen Threadripper CPU, but I can't make it run to the advertised 3200 speed. I can get it to run at 3066, the problem is also is that the Windows memory test feature shows a hardware problem, and the memtest86 shows also shows problems, so I don't know who to call now.

Before I purchased the kit, I contacted the mobo manufacturer and confirmed the kit I was buying was going to be compatible.

Thanks,

Comments

  • 4 months ago
  • 1 point

What happens if you lower the frequency to 2933MHz and do the tests again?

  • 4 months ago
  • 1 point

I'll try it again, but I run so many tests, that I believe it'll be same, Windows 10 will boot, but the memory test will show the hardware problem found message.

Thanks,

  • 4 months ago
  • 1 point

Even at 2933MHz?

  • 4 months ago
  • 1 point

The memory problem with the test feature on Windows, I believe so, but I'll double-check again.

Also, I have tried using just 4 memory sticks, and computer won't even boot.

Thanks,

  • 4 months ago
  • 1 point

Did you install them into the appropriate Ram slots?

I assume you have a 8x16GB kit?

  • 4 months ago
  • 1 point

Yes, I installed the sticks like the manual said. I've been running 32GB 4 x 8GB for the past year, so I use the slots like my previous configuration to install the 128GB.

Right now I'm writing from that PC, but using the older 32GB kit.

Thanks,

  • 4 months ago
  • 1 point

Just a quick update, I did the Windows memory test at 2933, just a basic test, 1 pass because I don't any more time today, and test showed no problems.

  • 4 months ago
  • 1 point

Run a stress test and check stability first.

There is an odd clock speed bug with the first Ryzen architecture where on some silicon the non-standard base clocks cause memory misses until the next cycle, it shows as a fault but is only a delay not an actual fault.

When I had my 1700 it couldn't pass a memory test to save its life but would handle 3600mhz speeds without crashing for 24 hour stress test.

  • 4 months ago
  • 1 point

Thanks for the advise, actually, I have a second gen Threadripper 2950x.

  • 4 months ago
  • 1 point

The way AMD set them up by using 2-4 CPU to get the end core count doesn't help since it only takes one to be ever so slightly out of sync with the other and they will show a fault as well.

  • 4 months ago
  • 1 point

Also, I wanted to point out that I have tried using only 4 memory sticks, and computer won't even boot, so I couldn't get to BIOS to change speeds.

  • 4 months ago
  • 1 point

Have you updated your BIOS?

Something is way off if it won't work with an easier load.

  • 4 months ago
  • 1 point

Yes, the mobo is using the latest BIOS update. Actually, I updated the BIOS right after I started noticing issues.

  • 4 months ago
  • 1 point

Update:

I installed the RAM again, and it's been working OK, but only at 2933, at 3066 it works, but for some reason, Task Manager doesn't show info, such as speed, slots used, form factor, and hardware reserved.

I done a basic Windows memory test, 1 pass, at 2933, and the memory passed the test without errors.

The kit is rated for 1.35v, and it's what the BIOS is showing right now.

Yesterday, I took the BIOS battery out of the PC, and reset the BIOS settings, but I'm still dealing with the same issues trying to run it at 3200.

My older RAM, 32GB kit, 4 x 8GB, were rated at 3200, and they worked at 3200.

Any other suggestions?

If I can't get the memory to run Windows 10 at 3200, does it mean that the memory kit has problems?

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube