add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Weird GPU Fan problems? (AMD PowerColor Radeon RX 5700 XT)

SgtStrid

1 month ago

Hello all, I have a Powercolor Red Devil 5700 XT. I am having a problem with the fans, or possibly the software that control's them. I'm currently just using AMD's Wattman, Witch i had no problem with for quite a few months, But just recently i crashed out of a game (space engineers) with the prompt that my GPU may be overheating. After having a minor heart attack (as this is a relatively new build (and my first build)) i thought i had something wrong, After looking at the GPU i noticed that the fan's were not moving at all, Witch is strange because with the fan curve i had set up, there should almost never be a time when they are stopped, (i don't mind a little extra noise if it means i can keep my parts cooler, and safer.) Went into Wattman and found i could control nothing The option was there But even setting fan curve to 100% across the board wouldn't raise the RPM. So i tried restarting computer Nothing changed, Thinking i might have a bug, i uninstalled, then reinstalled AMD drivers Still nothing. After that I installed a earlier version this is the only thing that made any difference at all. Now i can control the fan's But they still seem strange Like if they are not doing what the program says quite right. Also if i set it to the auto fan curve it will do nothing at all No matter the load, And before it worked perfect (i just dident like using it cause i heard it's not "Aggressive enough". I Also updated the Bios hoping that might fix it. I have tried doing some research but i'm still not sure exactly what wrong. or what i can do to fix it correctly. I really like this computer, And i've only had it a few months i'd like to keep it a few more years, so here is to hoping someone know's what's happening and has a perfect fix! CX Thanks for any help, and If any more information is needed please feel free to ask.

Comments

  • 1 month ago
  • 1 point

Fan control of Radeon cards has been hit or miss since Vega.

Some drivers it works on some cards, some all cards, some you just live with it and no cards work.

Navi has taken the issue to a whole new level sadly but AMD has said again they are looking into it.

https://youtu.be/pboDbxogSw4

Part of the problem is AMD rolling out firmware fixes as part of the driver package which stays when you revert to older drivers.

Maybe within a couple months it will work again hopefully longer then a driver version or two.

  • 1 month ago
  • 1 point

Ah, so it's not somthing with the card, Just the software? Also should i worry about card damage, since the prompt mentioned something about overheating? or is there some way i can check it? Because even though i cannot return it at this point, i might be able to RMA for a new one if i gotta. Thanks for the info, It's very helpful!

  • 1 month ago
  • 2 points

Its software, the problem is it's on AMD's end of the control so there isn't anything you can do when it pops up.

You can try to contact the company and see what they say about the issue since the card should have throttled before shutting down.

But they may just tell you it's a driver issue that AMD is working on.

  • 1 month ago
  • 1 point

modern cards fans won't spin until needed, that I'm aware of, this could have been what was going on initially when you thought a problem existed. idk. after reading what gilroar wrote, it's "possible" you can flash the firmware to an earlier version, https://duckduckgo.com/?q=flash+radeon+5700+xt&t=ffsb&ia=web , then clean the installed drivers completely out, https://www.guru3d.com/files-details/display-driver-uninstaller-download.html , installing a driver version that seems to work better. Just an idea and possible solution, "or" , you can possibly return the card saying it's faulty.

Good luck.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube